Se dopo aver aggiornato la buona Archlinux e di conseguenza i driver NVIDIA con il fidato pacman -Syu vi siete ritrovati ad avere problemi con il tool di configurazione nvidia-settings, molto probabilmente è a causa di libpango o meglio del link libpangox-1.0.so.0 che non è presente e dovrebbe puntare a libpango-1.0.so.0.3200.1.

Per ovviare al problema basta dare questo comando che creerà il link simbolico mancante e rimetterà in sesto il buon nvidia-settings.

sudo ln -s /usr/lib/libpango-1.0.so.0.3200.1 /usr/lib/libpangox-1.0.so.0

Se è andato tutto come si deve, avrete il vostro nvidia-settings funzionante.

 

GNAM GNAM A TUTTI:)

 

 


3 Risposte a “Driver Nvidia 304.60 – Problemi con nvidia-setting e libpango su Archlinux – SOLUZIONE”
  1. idevoig scrive:

    Certe volte mi chiedo perchè scrivere la versione di una libreria, capisco la ricerca oculata sulla versione legata al binario, ma perchè complicarsi la vita… in fondo le librerie hanno sempre lo stesso nome…
    Passavo di qua, in previsione di un aggiornamento nvidia, verificavo i problemi.
    Mi fa piacere il tuo passaggio ad arch. Ricordati che è rolling… come me, tra la vita ed il pc, vince la vita, le rolling possono farti incxx molto, o aggiorni sempre e segui ogni passo e problema, oppure passi alle distro stabili e durature, quelle che quando le installi fanno sempre il loro sporco lavoro incondizionatamente se le guardi oppure no. In fondo sono come le donne, o gli corri dietro, o te ne trovi una fissa :) (o magari tutteeddue!!) cià, grazie per la segnalazione del problema nvidia, adesso installo :)
    (debian o suse o U.lts e wip Arch) :)

  2. Sammy scrive:

    Ha avuto lo stesso problema. Sei un risparmiatore di vita.

  3. miglior happy hour

    Driver Nvidia 304.60 – Problemi con nvidia-setting e libpango su Archlinux – SOLUZIONE | Monolite's Weblog

  4.  
Scrivi un Commento